Jump to content


Please note: You can easily log in to MPN using your Facebook account!

Kurzweil PC3LE88


Caseymour

Recommended Posts

I purchased this keyboard new about a month ago. Last night at a gig, before we even played, the screen went blank, meaning it was still lit, but the text was all gone, and all the lights on the keyboard started flashing and wouldnt stop until I rebooted and then did the same thing again. I also use a Yamaha XF7 as my main controller. I had no issues with the Yamaha, so its not a power issue since they get their power from the same place. I see over the internet, that there are a lot of problems like this but no solutions. I am running the latest OS update also. Any help would be greatly appreciated. Thanks!!
Link to comment
Share on other sites



  • Replies 7
  • Created
  • Last Reply

Caseymour -

 

Fear not!

 

After paying twice to have this problem fixed (I have a PC3LE6), I became aware, via the Keyboard Corner, that this is a "known problem." I have since had the keyboard fixed, and so far, so good.

 

What to do: Get in touch with Jean (Kurzweil tech support) and/or make sure that your local authorized Kurzweil service center gets in touch with the tech people at American Music and Sound (Kurzweil's distributor). They have issued a repair bulletin regarding this problem, and will make sure your local repair person is up to speed!

 

Good luck, and let us know what happens!

Link to comment
Share on other sites

I had the same problem with my PC3. It was a loose ribbon cable on the circuit board. It was the cable labeled "front panel". You can also write a mail to kurzweil support. They are very supportive!

 

good luck.

 

 

Rudy

 

 

Link to comment
Share on other sites

RudyS -

 

Not sure you're talking about the same problem . Many people reported a blank display which was due to a loose or detached cable, that was user-fixable.

 

Did you also experience a rhythmic flashing of all of the lights on the front panel? THAT'S the problem that Caseymour and I had - now, there is known fix, which involves either modifying or swapping out one of the internal boards.

Link to comment
Share on other sites

Rodan is right on the money. The LE issue is a hardware issue. There is even a video displaying the issue.

 

http://m.youtube.com/?#/watch?v=kZ9vSVIKtBM

57 Hammond B3; 69 Hammond L100P; 68 Leslie 122; Kurzweil PC3; M-Audio Code 61; Voce V5+; Neo Vent; EV ELX112P; GSI Gemini & Burn

https://dyinbreedband.wixsite.com/dyinbreedband/home

facebook.com/smokingunsrock

facebook.com/acoustaxx

Link to comment
Share on other sites

RudyS -

 

Not sure you're talking about the same problem . Many people reported a blank display which was due to a loose or detached cable, that was user-fixable.

 

Did you also experience a rhythmic flashing of all of the lights on the front panel? THAT'S the problem that Caseymour and I had - now, there is known fix, which involves either modifying or swapping out one of the internal boards.

 

Okey. Sorry, i did not know this!

Rudy

 

 

Link to comment
Share on other sites

  • 3 weeks later...

I responded on a different thread for the same problem, but I'll copy my response here so you are aware of a fix:

 

I bought a used PC3LE7 a few months ago and experienced the same flashing lights issue. I contacted Sam Son(sson@ycapiano.com) at young chang pianos and he found the fix from the manufacturer. I am in Canada so you may have a different support center you need to contact. Sam was fantastic and saved my keyboard from being thrown in the garbage! The fix involves removing a specific capacitor on one of the internal circuit boards, replacing 2 power cables, and updating the boot loader and OS. I was able to do the fix myself as I have some background in electronics, but I'm sure a service center would do it. It's been a week and the keyboard has been solid. BTW, while I was waiting for the replacement cables I opened up the unit and re-seated the existing 2 power cables, which made the kbd start working although it was just a temporary workaround.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...