Jump to content

Please note: You can easily log in to MPN using your Facebook account!

Strange symptoms in my Ensoniq KT 76


Recommended Posts


I have this keyboard since March 95, with very good results although I´ve NEVER get it out of my house.

Since two months ago, each time I turn it on, no button responds (either patch bank or multis), but if I turn it off and on again, it works OK.

A week ago when I turned it on and I pressed a button for checking, it displayed "Button #59" with no other legend.

Ah! I forgot, the Startup message display sometimes appears "moved" two or three letters to the left, for example "nsoniq KT 76...Blah blah"

Is it time to change batteries?

Is there batteries for sale?

Is it time to bury the old friend?

Any help appreciated.



Link to comment
Share on other sites

  • Replies 12
  • Created
  • Last Reply
  • 7 years later...

Did you try a hard reset? To do this you must cycle the power on/off 7 times as follows;


Flip the power switch on, and as soon as characters appear on the display, flip the power off. repeat that 7 times and on the 7th power up, leave it on. If the problem is software related, this should clear it up.



Wm. David McMahan

I Play, Therefore I Am


Link to comment
Share on other sites

Similar problem with a VFX - circa 1992? In efforts to get it repaired I was told it was something to do with the main board (mother board?) and those were no longer available. So not wishing to pursue any further, a GAS attack was satisfied and today the Ensoniq remains in a dark dusty corner of my basement.


Gig Rig: Yamaha S90 XS; Hammond SK-1; Rehearsal: Yamaha MOX8 Korg Triton Le61, Yamaha S90, Hammond XK-1

Retired: Hammond M2/Leslie 145, Wurly 200, Ensoniq VFX

Link to comment
Share on other sites

With Ensoniq KT-76 i made the 7 time on/off cycle ... same symptoms...It's always the same and repeatable . Switch off,waiting for 1 minute then turn on , the message is not "centered" a little outside of the lcd screen.Then Rom 00 KT Grand Piano plays ok but nothing else.You can not change sounds no buttons work . After 2 minutes i power off and on again , now it's ok. Every button works as expected. When i switch off after hours of playing then the same symptoms appear... i think it's service time or living with it.
Link to comment
Share on other sites

  • 1 month later...

I am having this exact same issue with my E-Prime! Did you ever figure out what is the problem? I tried this 7 cycle power reset and it did not do anything. I have also tried the reset method of pressing the 3 buttons but since the buttons don't register this did not work either. Any ideas?



Link to comment
Share on other sites

I am 99% sure it's a battery issue. (Even in the case of the new battery-check battery contacts if button cell type or battery solder joint on the older Ensonig boards-ESQ's SQ's VFX's-even old Mirages.) I'm an Ensoniq user from way back in 86 with my 1st ESQ-1 that I still use today running OS 3.5. Most incarnations display a battery warning but that's not always. That other 1% can include a lot of variables including a tired power supply, bad/loose solder joints on the actual digital display (very common problem) or even a bad PC board connection on any thing from the SQ-1's up to the KT 88. Couple of sources you can check are http://www.syntaur.com/ Sam Mims and Syntaur productions. (Ancient purveyor of groovy stuff for older synths including all of the Ensoniqs. One of the few Ensoniq Gurus left), and http://bullcitysound.com/ in Durham, NC. Talk to Russ. Tell him Archie from Durham sent you :)

"Life Is Just A Game And They're Many Ways To Play...All You Do Is Choose." SC 1976


Fantom, XP 80, DX7 IIFD w/"E", Ensoniq ESQ 1, Roland Alpha Juno 2, Roland S 10, Korg Triton LE with EXB, GEM RP2

Link to comment
Share on other sites

  • 3 years later...


This topic is now archived and is closed to further replies.

  • Create New...