Jump to content


Please note: You can easily log in to MPN using your Facebook account!

Removing Virtual Mains in Sonar


Recommended Posts

Has anyone tried to reduce the number of virtual mains in the Options|Audio setting in Sonar? Once you reduce the number, any previous projects that you saved with the higher setting will no longer open, regardless of whether you're actually using all of those virtual mains. I'd really like to reduce the default number, but I can't find a way to remove the reference to all of those mains in my older files (hiding them doesn't help). I'm using Sonar 2.1. Any suggestions would be appreciated.
Kevin
Link to comment
Share on other sites



  • Replies 4
  • Created
  • Last Reply
Well, just for kicks, I opened a file, reduced the number of mains from 8 to 4, and saved it under a different name. Of course, I was warned that changes wouldn't take effect until I re-started the program. Fine. So I quite, restarted, and called up several older files that had previously used 8 buses. They opened just fine. Are you sure you don't have some data in those extra buses somewhere, or tracks that reference the extra buses as outputs?
Link to comment
Share on other sites

Thanks Craig. I was assuming that changing the default did not change the currently open file (you can change the default without anything open). Well, it does work, but it's still a bit laborious. I would have to first set the Sonar default to 6 virtual mains. Then I need to open an older file, change to the new number of virtual mains, and then save. Then I'd need to close the file, change the number of virtual mains back to 6, and restart Sonar (I think). Then I can move on to the next file and repeat for each of the 50 or so projects I have saved. It works at least. Thanks for the help.
Kevin
Link to comment
Share on other sites

That definitely does not work for me. Changing the default to 2 (for instance) will not allow me to open any file that was originally saved with the default set at 6. Every old file I open gives me the following error message: "Virtual main buses used by project(5) exceed current setting (3). Please increase the configured number in Options|Audio|General, and restart prior to loading this file." I've sent the same question to Cakewalk, but I haven't received a response yet. I'm using Sonar 2.1 running on Windows XP Professional. BTW, thanks for the column in SOS. I've been reading the internet version of SOS for a few years now and its great to finally have articles on Sonar (which is apparently not as well known in the UK).
Kevin
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...