Jump to content


Please note: You can easily log in to MPN using your Facebook account!

Please help! :'( Midi . Studiologic SL88 Studio


Recommended Posts

Hi all,

 

In short the request is :- please try to find my user error and help me!

 

Scenario: - I just got the Studiologic SL88 in the post this afternoon, and immediately went to try and set it up.

 

I'm using it with MainStage 3.

 

First step - out of the box, USB. The joysticks send midi information. Any pedals I plug in send midi information, I can send program changes too if I set them on each zone!

 

The keys themselves - nothing.

 

So I try over a midi cable. I set it to Midi 1, instead of USB, and now I can send the same midi signals, but still no keys.

 

Next thing I tried. I took a keyboard with sounds, plugged it's midi out into the midi input of the SL88. Everything I played on this keyboard did manage to get through the Studiologic, to the computer.

 

Next thing I tried, trying to trigger the sounds of my keyboard from the SL88 studio. Again no use, but the pitch bends etcetera all worked.

 

Is there something really obvious I'm missing, because I don't know much about midi?

 

The midi channel shouldn't make a difference, since MainStage should still see it , no matter how it is set.

 

I've also tried in Logic Pro. Same deal.

 

I tested out of the box all the same tests, then I upgraded the firmware, and performed all the same tests, but nothing changed.

 

All 88 keys send nothing!

 

I've already contacted Studiologic, and Thomann who I bought it from, but I'm hoping the wisdom here could help me if they are not helpful.

 

I'm really losing my mind over this :( . I feel very sad, I was excited to play it, and I spent around 4 hours today tearing my hair out trying different things!!

 

I really hope there is some stupid user error on my part , because if I have to ship it back to Germany it's going to cost an arm and a leg!

Link to comment
Share on other sites



  • Replies 11
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Take a look at the editor in Svens post. Assuming youve selected your MIDI connection, have you done what the manual says?

 

On the GLOBAL/MIDI page, set MIDI 2, SL Port 2 or USB Speakers 2 as IN and OUT device and then click CONNECT; this action will immediately set the communication between the SL and its EDITOR and you will see the keyboard drawing, at the bottom of the Editor, painted with a different colour, for each one of the four Zones.

 

 

 

____________________________________
Rod

Here for the gear.

Link to comment
Share on other sites

Thank you for your responses!

 

That doesn't seem to be it :(

 

I don't have any problem connecting to the SL Editor as in the manual, and seem to have no problem affecting parameters in the keyboard through the editor.

 

So I connected over USB as described... can control keyboard parameters, and see them moving on the keyboards screen....

 

I didn't think to check key range and velocity , but they are as factory 1-127, key range is all 88 keys, and all are going over USB, and are on midi channel one!

 

Later I want to send it direct to my sound card with midi, but for now I'd just like it to work, and then if that happens I imagine switching it will be easier.

 

Any other ideas? I've already tried disconnecting other stuff. The USB Socket works. When I remove it, MainStage recognises that a midi input is gone, and the joystick data sends fine. Also I normally use that USB with an MPC controller, so I don't think that could be the problem either.

Link to comment
Share on other sites

Maybe a ribbon cable from the Key bed came loose in shipping?

Dan

 

Acoustic/Electric stringed instruments ranging from 4 to 230 strings, hammered, picked, fingered, slapped, and plucked. Analog and Digital Electronic instruments, reeds, and throat/mouth.

Link to comment
Share on other sites

because if I have to ship it back to Germany it's going to cost an arm and a leg!

 

Return it

 

Youve checked this out already, Im sure. The only other option I can suggest would be to call a fellow MIDI musician over for a one on one.

 

:idk

____________________________________
Rod

Here for the gear.

Link to comment
Share on other sites

Just throwing this out there since I didn't see it mentioned... did you assign the keyboard in Layout mode in MainStage?

MainStage; Hammond SK1-73; Roland XP-80, JV-90, JV-1080, JV-1010, AX-1; Korg microSAMPLER;

Boss DR-880; Beat Buddy; Neo Instruments Ventilator; TC Electronic ND-1 Nova Delay

Link to comment
Share on other sites

Thanks everyone!

 

Alas no, it's not because I'm in layout. The real issue is the keys (and only the keys themselves) not sending any midi information.

 

I'll try midi monitor a little later.

 

Studiologic haven't replied to me yet. The ribbon thing sounds plausible.

 

If midi monitor also detects nothing , I suppose I better start talking to Thomann about sending it back. I already started e-mailing with them about the problem, but they haven't said anything new

Link to comment
Share on other sites

  • 4 years later...

My SL didnt work out of the box. Something to do with assigning all four zones causing problems. I edited a ‘patch’ and turned three zones off, setting the remaining zone to whatever output I needed (MIDI1, 2 or USB). Checked that matched my connection (easy to connect the wrong midi port) checked the receiving hardware was on the right channel and voila all good. If you do this and still nothing no matter what you set then something is faulty. If USB works, I would definitely check the other gear as its unlikely to just be a MIDI fault on a new piece of gear.

The four zone thing has been raised on several other forums which is where I discovered it. If you get it working, use that as your default setting as work from that for the others.

Korg Grandstage 73, Keystage 61, Mac Mini M1, Logic Pro X (Pigments, Korg Legacy Collection, Wavestate LE, Sylenth), iPad Pro 12.9 M2 (6th gen), iPad 9th gen, Scarlett 2i2, Presonus Eris E3.5

Link to comment
Share on other sites

  • 2 months later...

Hi Everyone! My English not the best but I wanted to ask If you fix you problem??

I have Sl Editor did upgrade for version 1.7.0 after everything connecting very good

but its second day I still cant here the sound I try connecting only with USB because I dont have a MIDI cable yet

I want to play Because waiting very long for this instruments and NO SOUNDS make me little sad What i need to do

because I want to here the voice of synth;(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...