Jump to content


Please note: You can easily log in to MPN using your Facebook account!

pops and clicks with Ravenscroft


chas50

Recommended Posts

hey gang,

am starting this thread to ask please for help with Ravenscroft.

I get pops and clicks.

this is with it running in UVI workstation. I just upgraded to the newly released FLAC file.

I tried to run it in Cantabile. Cantabile does not see it.

I run American Concert D in Cantabile. no troubles at all.

I compared my memory and CPU usage between Ravenscroft running in UVI and ACD running in Cantabile.

Ravenscroft (with all 4 mics turned on), uses way way more.

would be most grateful for any help with this.

my computer is a less than 1 year old HP Envy notebook. i7. 8Gb ram.

Windows 8.1.

focusrite Scarlett 6i6 interface.

the piano files are on an mSATA SSD.

I had hoped that the new smaller Ravenscroft file size would solve this problem. it does not.

 

 

Link to comment
Share on other sites



  • Replies 34
  • Created
  • Last Reply

just emailed. thank you.

 

update:

wow!! heard back from Lance already.

excellent reply. told me a lot of stuff. increase buffer size, use less mics (not all 4), and more.

really impressed with the speed of the reply, and the stuff he said.

really super customer support. on a Sunday evening. wow!! very cool. thanks alot Lance.

Link to comment
Share on other sites

just emailed. thank you.

...

excellent reply. told me a lot of stuff. increase buffer size, use less mics (not all 4), and more.

So did these steps resolve the problem? No more pops and clicks? I'm curious...

 

- Guru

 

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

:thu: Nice that you're happy with it.

 

Doesn't a single microphone setting mean mono? That seems like a rather harsh compromise, IMHO - unless I'm missing something. I can't shake the feeling that it should not be necesary, given the sheer horsepower in your setup. Also, I'm curious as to what buffer size works for you.

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

hmm. not sure about the mono question. I'll have to check it out.

whatever it was, it really really sounded great. I mean superb, heavenly great.

I'll also have to check my buffer size. I did not even look to check it.

I'll do some research and post again with more info.

Link to comment
Share on other sites

I just checked some stuff. (still have to find out about the mono with 1 mic question.)

my audio driver: ASIO focusrite usb 2.0

sample rate: 44100 Hz

buffer size 442 samples (thats the lowest it goes)

latency 10.0 ms

Audio Engine

multi processor support: Enabled (compatibility mode)

sample rate conversion quality: better

 

I played RC in UVI in Cantabile.

my task manager said the memory was 52%. it stayed there. it barely moved whether I was playing or not.

the cpu usage fluctuated from 2% to 11%.

I played with 1 mic. the close mic.

I played madly. with the sustain pedal. I really gave it a work out, a run for its money.

the sound was pure heaven. there were no pops, no clicks, no dropouts.

in my very humble uneducated opinion, RC is a screaming deal. it is so good, I am having a hard time coming up with words that really say how much I love it.

 

Link to comment
Share on other sites

buffer size 442 samples (thats the lowest it goes)

I'm surprised that it doesn't go lower. 442 is on the higher side. Have you tried the default settings of 4 mics with this buffer size, in Cantabile? I'd be surprised if you get still get pops and clicks. This ought to make the sound a richer, fuller stereo.

 

Don't get me wrong, it's nice that you're happy with the sound that you have. But given your specs, I just get the feeling that you should be able to have a far better performance. Which means a richer, fuller sound at much lower latencies - which amounts to an even better playing experience than you've had so far. I'm just curious to understand what's holding your system back.

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

thank you very much for your great reply Guru.

I don't know a lot about this, but I did think that 442 seemed high.

I looked around a bit. I found no way to make it go lower.

this is using the Focusrite Scarlett 6i6.

I just googled for info about that interface and found this:

"After I'd installed the software, everything worked first time, once I'd selected the Scarlett 6i6 as the active interface in Logic Pro. I found that it recorded and played back reliably at buffer sizes down to 32 samples, which gives a round-trip latency of just 6.3 milliseconds at 44.1kHz."

 

hmmmm. wondering if Cantabile or UVI are the bottleneck for why the buffer size only goes down to 442.

 

as for playing with more mics, yes I will have to try that again.

 

Link to comment
Share on other sites

You should be able to use the Sample Rate Slider in Options-> Audio Engine Options to reduce the buffer size to a reasonable 128, or even 64. If not, my first guess is that the Scarlett drivers may not correctly installed. Try downloading and installing the latest driver from here. Reboot, and see if you can reduce the buffer size.

 

If the problem still persists, check if you can reduce the buffer size in Ableton Live Lite that usually comes bundled free with the Scarlett. And if it still persists, you should contact Focusrite support - this has nothing to do with Cantabile or VI Ravenscroft...!

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

wow!

thank you very much for your very helpful reply.

I gotta check this out.

 

update: just checked my Focusrite manual. I see how to change the latency buffer size setting.

the way it works, is that you select a ms number.

I have it set at 10 ms right now.

I will set it lower. and try using more mics.

 

edit update again:

found this on VI Labs website:

"Close mics are inside the piano and have a detailed punchy sound with wide stereo image."

so, with the Close mic selection, it is saying that there are 2 mics, to give a stereo sound.

here's a link for more:

 

http://www.vilabsaudio.com/Ravenscroft-By-VI-Labs

here's more from that page regarding stereo/mono:

 

"Complete sound control

The bottom corners of the interface contain the Stereo Width and Channel Flip functions, Tone control and Timbre Shift on the left with Reverb level and selection on the right.

Stereo Width is a new feature of the Ravenscroft 275 VI and allows you to have a more narrow stereo image if desired or create a full mono signal. The default of 100% is the sound as recorded by the mics. If its set to 1%, both left and right mice are summed mono. However, if this knob is set to 0%, only the Right microphone is heard as the mono source. If the Flip button is turned on, the mono source comes from the Left microphone instead. This allows for a clean phase-free mono sound. The Flip button above Stereo Width swaps the Left-Right image when Stereo Width is anywhere from 1-100%"

 

edit:

reduced buffer size to 3.0 ms (133 samples). Close mics only. played madly. no drop outs.

 

 

 

Link to comment
Share on other sites

am writing to please ask for any thoughts.

I loaded all 4 mics. played madly. including using sustain pedal alot.

tons of clicks, pops, dropouts....whatever you call them.

I raised the buffer size up to 7 ms.

same problem.

 

to repeat, my computer is an HP Envy 15j t100 notebook.

8 Gb RAM. i7 4th gen processor. Ravenscroft file is the new FLAC file. its installed on the SSD that I installed.

 

I look in task manager.

with no programs open, the memory says 19 %.

with Ravenscroft open in UVI in Cantabile, with all 4 mics, the memory says ~80 %.

the cpu says ~11%.

any thoughts about this?

should I install another 8 Gb of RAM?

or do you think its some other problem?

(for example, maybe its just not possible with the state of the art technology, to play this many notes and use the sustain pedal, and expect it to work, and for there to be no dropouts?)

Link to comment
Share on other sites

reduced buffer size to 3.0 ms (133 samples). Close mics only. played madly. no drop outs.

Ok, it's good to see that there's some progress! At least, your latency is reduced, so there's a better finger-to-ear connection. :thu:

 

It's still slightly surprising that you aren't able to use the default mic configuration on an i7 machine with 8GB of RAM. To check whether there are any issues with your system, download and run this diagnostic tool: LatencyMon. Click here for instructions on how to use it.

 

This will let you know if there is any rogue driver that is affecting your system performance.

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

thank you so much Guru.

will do.

update: just did a test run on a different computer. (I am not with my HP Notebook laptop that I use for playing my piano programs with.)

 

when I run Latency Monitor later, on my HP Notebook, how long should I run it for? (it seems like Latency Monitor will just keep running until I click stop.)

edit: a friend just gave me this link:

http://www.native-instruments.com/en/support/knowledge-base/show/752/windows-7-tuning-tips-for-audio-processing/

Link to comment
Share on other sites

when I run Latency Monitor later, on my HP Notebook, how long should I run it for? (it seems like Latency Monitor will just keep running until I click stop.)

I think a few minutes should do - as much time you have to typically wait to hear the pops and clicks. Just to be safe, I'd run it for, say, 20-30 minutes.

 

Oh, that's gold. I was about to suggest a very similar set of tweaks. Following all the instructions there should certainly give you a much better performance. But the list is for Windows 7, here's the same list for Win 8.

 

I'm curious as to whether other Ravenscroft experience pops and clicks with 4 mics.

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

thank you so much again Guru. (I don't remember, do you have Ravenscroft? and if yes, how do you like it?)

 

and SK, thank you so much. how do you like Ravenscroft

 

just wondering, because I think its really phenomenal. I mean I'm blown away by it.

Link to comment
Share on other sites

:thu:

 

Glad you're happy with the performance, @chas50. I haven't bitten the Ravenscroft bullet yet - which is why I assumed 4 mics was the factory default. As long as you can run factory default settings at around 133 samples, that's decent performance. Enjoy your new piano!

 

- Guru

This is really what MIDI was originally about encouraging cooperation between companies that make the world a more creative place." - Dave Smith
Link to comment
Share on other sites

SK, thank you so much. how do you like Ravenscroft
chas50, I like it a lot - more than any of the software pianos I've owned/tried so far.

 

It's natural for pianists to have expectations of what a piano should sound like, based on years of playing Steinways, Baldwins and Yamahas, etc. So although I might not necessarily prefer a Ravenscroft acoustic over some of the brand pianos (that we associate with a piano sound), this software has given me a genuine respect for the Ravenscroft.

 

I haven't played a Ravenscroft acoustic, but the sample reveals a lot about the instrument... and it has its quirks which are not necessarily a bad thing. It does have a slightly smaller sound for its size. It's also oddly both dark and very bright, very expressive, and is clearly a musical, high quality instrument. Its sympathetic and pedal resonance is really remarkable.

 

As for the software itself, Vi Labs deserves kudos for developing it and setting a new standard.

 

Link to comment
Share on other sites

thanks so much SK. fascinating post.

I really really like the sound of the Ravenscroft VST.

I have very limited experience playing high end acoustics.

I made a bunch of tweaks on my computer per suggestions from links in above posts.

I ran Latency Monitor again (after making tweaks).

I have attached pictures of the results.

any thoughts SK, Guru or anybody?

this is with my Focusrite Scarlett 6i6 interface set for 3 ms, which is 133 samples.

it seems to be running pretyy good now

also, it is with Ravenscroft loaded with 3 mics (not the room mic).

I do want to mention one interesting experience.

I was playing. the cpu usage was ~13% up to ~26% (but mostly between 13-19%). the memory was at 64%.

then all of a sudden, severe pops and clicks. the disk column (next one after cpu and memory), went from 0 to 50%.

I stopped playing. the disk went back to 0. the memory actually dropped to 55%. I played more.

the cpu was ~15-20%. the memory went back up to 59%.

but no more clicks or pops.

any thoughts most welcome. thanks alot, Charlie

 

okkkkkkkkk, I don't know how to put pictures (I used the snipping tool and saved the pictures on to my desktop).

would someone please tell me what to do?

I have a Dropbox account.

 

update: it did the same thing again. working fine, then wham......super click, pop.........very dramatic.

something wrong here. emailed support. have not heard back yet.

any help with this problem greatly appreciated gang.

 

 

 

Link to comment
Share on other sites

You're welcome, Charlie. I can't address the sample setting for your equipment, but here's a few more thoughts:

 

A matter of tastes: a lot of people like the close mic or player the best, or a combination. For me, the side mic is best for the solid body sound of it, with just a touch of one or two of the other mics to round the sound out. Full volume settings on 3 mics just sounds to me like overlapping recordings of three pianos - louder, but not as solid. So experiment with the mic volumes to find what you like.

 

Also, two things definitely improve the sound: The higher you can set the polyphony on the Ravenscroft interface ("max" being the best), the better it sounds. And if you have a good piano action controller, the sound and response is even better.

 

Good luck with your experimentation, and enjoy it!

Link to comment
Share on other sites

thank you very much SK.

I really love the sound of 3 mics together (leaving the room off).

my controller is a Kawai CA65. I like it alot.

I will look at the polyphony setting. I have not adjusted it.

I will check other mic combos as well.

any other help most welcome gang.

no word from Lance yet.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...