Jump to content
Please note: You can easily log in to MPN using your Facebook account!

Electronic gurus and troubleshooters... help! :)

Jim Alfredson

Recommended Posts

I purchased a Yamaha CS50 really cheap off craigslist last weekend. Unfortunately only one voice is sounding right now. I replaced all the caps and CMOS chips on the S&H board thinking that was the issue. I also recapped the PSU and adjusted the voltages to within .05v of spec. Unfortunately none of that solved the problem(s).


The good news is that by jumpering from the main output of the card to the inputs/outputs of various chips, I can tell that there is signal (ie audio) from the oscillators on each card. So the oscillator, waveshaping, and filter chips are all working on each card. It seems that signal on each card is getting stymied at the first VCA, IC4, the elusive Yamaha IG00151 chip. But I'm not sure if it's actually the VCA or the VCA EG chip, IG00152, controlling that VCA. Or perhaps IC5, another IG00151 VCA chip.


Schematic of the section in question:




Up at the top you can see the test points. CP2, CP7, CP8, CP1, and CP3... all have healthy audio signals from the oscillator. Once I get to CP5, right after the first VCA chip, the sound stops. On one card, there's no sound at all. On the other two the sound is there but it's very very faint.


I replaced all the electrolytics and tantalums on board number 4 last night and that helped a bit: It now has some audio at CP5 whereas before it had none. Some of the electrolytics had green legs, presumably from leakage.


Any help would be appreciated! Thanks!


Link to comment
Share on other sites

  • Replies 13
  • Created
  • Last Reply
Check CP4 for output. Check output on IC4 (0) and input to IC5 (+1)


Good call. I was going over the schematic and realized I missed that one.


Ok...starting with voice card M4




CP3 - signal at greater volume than from the working card's regular output... probably because it's not buffered (M1)

CP4 - much lower volume (lower than M1's regular output) but I can hear the filter EG affecting the sound

CP5 - nothing


IC3, IC4, IC5 - signal present at inputs and outputs, very low volume

IC6 - no input, no output




CP3 - same as above

CP4 - same as above

CP5 - nothing


IC3, IC4 - signal present at inputs and outputs, low level

IC5 - nothing

IC6 - nothing




CP3 - same as above

CP4 - same as above

CP5 - aha! signal, but very low level yet with filter and amplitude EG


IC3, IC4, IC5 - inputs and outputs present

IC6 - input yes but lower than everything else listed above, output no signal


So it appears voice card M1 is the best one to go by right now and attempt to fix first. It's almost functioning. Got signal all the way to the last VCA chip but nothing afterwards. The question is... is that because of the VCA chip, the components before / after the VCA chip or because the VCA chip is not being controlled correctly by the EG chip?



Here is the full schematic.



Link to comment
Share on other sites

All right, I got a little farther tonight. I'm pretty sure the EG chip on one of the cards is toast. The other two non-working cards seem to have functioning EG chips but a bad VCA (or more... hard to tell).


My big question: The VCA chip right next to the EG chip in the full schematic above, labeled IC2... what the hell does it do? It's input comes from itself and the output goes to the buffered input of the EG chip. Is it some sort of biasing?

Link to comment
Share on other sites

I showed Dad the schematic and here's what he said:


Since the output and lack of output is the same for all 4 voices, I would assume that it is not a component failure. It's unlikely to have the same component failure on 4 different boards.

This says it has to be something common to all 4 boards.

First suspect is the power supply. In first email, "voltages were adjusted within .05 volts of spec." Can we assume that this was both the +15 and -15 voltages? Were both voltages measured on each board or only at the power supply source?

Try measuring the voltage at "E1" terminal on VCA IC5. Should be very close to zero. Try E1 terminal on VCA IC4, since the output at CP4 was OK.


IC2 function: it appears that a signal from EG IC13, (LC) pin 13, feeds IC2 (+I) pin 3, and EG IC13 (IC) pin 12 feeds IC2 (EI) pin 1.

It works in conjunction with EG IC13 to shape the wave form.

Output of IC2 (O) pin 8, feeds IC13 (BI) pin 2.

Output of IC13 (OUT) pin 3 feeds IC6 (LI) pin 2. Output of IC6 (O) pin 8 feeds base of transistor TR8.

Output of transistor TR8 goes to output terminal "O".

Link to comment
Share on other sites

I adjusted the PSU under load for all voltages (+/- 15v, +8.5, and -6.5). I tested those voltages at various parts within the synth, too, including the voice cards. Everything checks out.


I know all four voice cards are receiving the right control voltages to trigger the voices. I checked test point LC on all four cards and they are all getting the same trigger voltage when a key is depressed in the right order (1 press for voice 1, 2 for voice 2, etc.)


I didn't get a chance to mess with it today but here's what I discovered last night:


Again, I think voice card 1 (M1) is the best candidate for restoration first because as noted above it is the only one with output at all VCA chips except IC6 & IC2.


I measured voltages from all the pins of the EG chip connected to IC2. All the voltages match the working EG chip from voice 3 except no output. On the working EG chip (which we'll call EG(3)), the output on pin3, when the corresponding key is pressed, goes from about 9v down to 6v as the EG chip shapes the envelope. On EG(1), the chip on voice card one, the output is nothing.


What does the output of EG(1) feed? IC6. So that's why there's no final output for the card. Nothing is driving the last VCA, IC6. It could be that IC2 is bad as well, but I'm pretty sure it's just EG(1). So, I'm thinking maybe I should apply a control voltage to IC6 on that board and see if it opens... if I get sound. If I do, then I'll replace EG(1)... after replacing all the electrolytics to make sure everything is stable.


For a control voltage, I'm thinking a 9v battery connected to a potentiometer so I can slowly open the VCA and see what happens. Or maybe just jumpering a signal from the working EG chip on voice card 2, M2. :)

Link to comment
Share on other sites

Yes indeed.


Gotta do a bit more probing but I'm pretty sure I have two dead EG chips and two or three dead VCAs. I found last night that the VCA chip that controls the aftertouch's routing to the sub oscillator is out, too. :(


Supposedly this guy (http://www.oldcrows.net/~oldcrow/synth/) has made a functional equivalent of the VCA chip using a modern chip and some other simple parts but he's not telling how. I found an old post of his on a messageboard last night where he said he was able to do it, though.


It's seems like there might be a way to adapt the THAT 2181 VCA chip to work in the circuit. That would certainly be preferable to buying old IG00151 chips and hoping they keep working.

Link to comment
Share on other sites

Ok, now for an update:


Last night I finished replacing all the electrolytics in the synth. The voice cards had a bunch of old electrolytics on them including some bipolars that I replaced with really high quality Japanese dipped ceramics.


I figured I'd start replacing the easier SIP VCAs, so I began with the one that controls the pitch aftertouch. Replaced it with the "new" chip I bought from the guy in California (thought he was in TX, but I was mistaken)... and it works! Yay! Pitch aftertouch sounds great!


Next, I replaced the dead IC6 VCA on voice card M2 with the other VCA I bought from the dealer (I bought two VCA chips and one EG). Yay, voice card M2 works and the filter EG works, too! This is in contrast to voice card M3, which I thought was the fully working card but then realized the filter EG isn't working. And lo, I have a duophonic synth!


Finally, I tackled the EG chip on voice card M1. I unsoldered the old chip carefully, installed a 16pin DIP socket, and installed the new chip, strapping the resistor on the bottom of the PCB instead of across the top of the chip like it was installed stock. I figured it would be easier to swap chips that way.


But oh no! It still doesn't work! The voltages from all the pins are the same as the chip I took out... really healthy rails, the trigger signal coming in on pin 7. But no output on pin 3.


So... does this mean that it's not the EG chip at fault, but rather it's companion VCA? And since the EG chip on the other non-working voice card M4 has the same voltages and the same problem with no output on pin 3, perhaps that is the problem there too, right?


According to a post on the CS80 Yahoo Group:


"The 159 is a linear timing/voltage sequence generator that uses the exponential input of the 151 to create the exponential sloped envelopes."


So it makes sense that if the corresponding VCA chip was dead, the EG chip would not be outputting the correct signal, right?


Oh how I wish I had socketed the "new" VCA chips, but I don't have any SIP sockets. I really don't want to unsolder the "new" chips and risk damaging them to test this theory, but I honestly don't see how it could be anything else unless this chip the guy sent me is bogus, too.

Link to comment
Share on other sites

Supposedly this guy (http://www.oldcrows.net/~oldcrow/synth/) has made a functional equivalent of the VCA chip using a modern chip and some other simple parts but he's not telling how. I found an old post of his on a messageboard last night where he said he was able to do it, though.


That's Scott Rider. He's a straight shooter and pretty much the font of info for all things CS. He designed the MOTM-480 and MOTM-485 filters.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...