Jump to content


Please note: You can easily log in to MPN using your Facebook account!

Traynor K4 problem???


Maze Sound

Recommended Posts

I bought a K4 about a month and a half ago. Last night I turned it on to practice and went to have dinner.I was gone about an hour and a half. Now when I turn it on it has sound coming out of the speakers that sounds like a fan running. I haven't even had this thing out of the house yet! Anyone else run into any problems with this particular amp?
SR guy thats finally decided to put his collection of toys to personal use (extremely G.A.S.'y) LOL
Link to comment
Share on other sites



  • Replies 7
  • Created
  • Last Reply

Mine has been fine for about 3 years now, not a hitch! Something must have gone wrong with the electronics. Alot of times there is one bad component or it happens in shipping.

 

It should be covered under the Traynor warranty which as I recall is pretty good. Bummer but fixable for free I would imagine.

 

SP6, CP-50, FP-80, PX5-S, NE-5d61, XK-3, CX-3, Yamaha YUX Upright, '66 B3/Leslie 145/122
Link to comment
Share on other sites

Traynor has a complete 2 year warranty for ANYTHING that happens to the amp. Take it back to the store and get them to give you a replacement while yours gets looked at.

 

You are aware of course that the amp does indeed have a fan that cools the tubes? Just checking....

What we record in life, echoes in eternity.

 

MOXF8, Electro 6D, XK1c, Motif XSr, PEKPER, Voyager, Univox MiniKorg.

https://www.abandoned-film.com

Link to comment
Share on other sites

Oh yeah. Already did the troubleshooting! I do sound on the side. I can usually isolate a problem quick. Fans aren't moving, everything disconnected, tried different outlets, put a Monster 3500 line trap inline on the AC, made sure the ground lift wasn't engaged, all gains and volume all the way off...... its the amp. Thought the spousal unit had turned the air purifier on......shit Had borrowed one form a friend that I cross rent from and used it for a month and a half before pulling the trigger. As a sound guy this thing has features that make my life much easier. I was actually impressed with the amount of engineering that went into it.
SR guy thats finally decided to put his collection of toys to personal use (extremely G.A.S.'y) LOL
Link to comment
Share on other sites

I had the exact same problem with mine when I first got it.

Just as our band started the 2nd song of our first set. The amp was making noises all by itself. It's real easy to remove the chassis and that's what I did making it easier to ship.

I believe I shipped it to the NY facility and they then shipped it to and from Canada.

This happened about 6 months ago and I haven't had a problem with it since.

Link to comment
Share on other sites

Actually I made out great. Called Musicians Friend and they sent me a mailer to return it for replacement, Its going to suck not having one for a week and a half, but they were great about it!
SR guy thats finally decided to put his collection of toys to personal use (extremely G.A.S.'y) LOL
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...